Access any data from the IUDX platform

Hi, I am a newbie and want to explore the IUDX data. I am able to successfully query the catalog and get access to meta-data. However, when i try to access the resources I get Internal server errors. Looking forward to receiving help from here.

Are you still getting those errors? Which data set are you looking at?

Hi, I am running this command from the command prompt and getting the same error. This is a snippet from one of the documents.

C:\Users\sanjana>curl -X POST -H "Content-Type: application/json" -d "{"id": "","time": "2019-10-30T09:30:00.000+05:30/2019-10-30T12:00:00.000+05:30","TRelation": "during" }"

Internal Server Error

Hi Sanjana. Looks like the quotes you are using are unicode quotes.
Here’s the same snippet with proper quotes.

curl -X POST -H "Content-Type: application/json" -d '{"id": "","time": "2019-10-30T09:30:00.000+05:30/2019-10-30T12:00:00.000+05:30","TRelation": "during" }'

Hi, For some reasons I am not able to post the output here. But the error exists.
I still get Internal server error along with a message that the 302 Found, the document has moved here response.

Can you give us the entire command again?

I am not able to post the output of the command you suggested me to try. It says my post is flagged.

Can you try the same now?

Can you paste the code using preformatted text option.

C:\Users\sanjana>curl -X POST -H "Content-Type: application/json" -d '{"id": "","time": "2019-10-30T09:30:00.000+05:30/2019-10-30T12:00:00.000+05:30","TRelation": "during" }'
Internal Server Error<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<title>302 Found</title>
<p>The document has moved <a href=",time:">here</a>.</p>
curl: (3) URL using bad/illegal format or missing URL
curl: (6) Could not resolve host: during
curl: (3) unmatched close brace/bracket in URL position 1:

Hi sanjana,

This curl command works fine for me.
Something seems wrong with your network or machine.


Oh ok. Can you please tell me if there is any environment setting that needs to be done before running this command.

These commands definitely work on Linux.
Give me some time to try them on windows and get back to you. Alternatively, you can use postman too by importing the collection.

Sure. Thank you so much.

Did you try the Postman collection?

No I haven’t tried it with the Postman collection. However in windows cmd I get the same error I mentioned earlier.

Can you try a different shell, like Powershell?

I have added the output screenshot below with this exact command that i tried with powershell.
But the error persists.