Flood data access


There is a problem in querying the flood data.
Please find attached the screenshot of the same.


Hi Nihesh.
Thanks you for bringing this to our notice.
Owing to the increase in demand for data, we had recently imposed a time duration constraint on “during” queries. Unfortunately, we have forgotten to add a suitable warning when your query exceeds the duration. This has been rectified.
If you now query for data which exceeds a range, you will get an exception raised telling you so and indicating the maximum allowed days (e.g, { “allowed_number_of_days”: 15})

Please find the updated jupyter notebook here

I tried running the sample jupyter notebook for flood data locally through my environment. However I get an error as shown below

RemoteError Traceback (most recent call last)
3 m = folium.Map(location=[18.5204,73.8567],zoom_start=12)
4 plugins.ScrollZoomToggler().add_to(m)
----> 5 flood_sensors = item.Items(“https://pudx.catalogue.iudx.org.in/catalogue/v1”, all_flood_ItemsByID)
6 print(flood_sensors[0].geoProperties)
7 for sensor in flood_sensors:

~\AppData\Local\Continuum\anaconda3\lib\site-packages\pyIUDX\rs\item.py in init(self, catUrl, items)
444 “”" Init items “”"
445 with Pool(4) as p:
–> 446 p.starmap(self.initItem, [(self.catUrl, item[“id”], self.list) for item in items])
447 p.close()
448 p.join()

~\AppData\Local\Continuum\anaconda3\lib\multiprocessing\pool.py in starmap(self, func, iterable, chunksize)
296 func and (a, b) becomes func(a, b).
297 ‘’’
–> 298 return self._map_async(func, iterable, starmapstar, chunksize).get()
300 def starmap_async(self, func, iterable, chunksize=None, callback=None,

~\AppData\Local\Continuum\anaconda3\lib\multiprocessing\pool.py in get(self, timeout)
681 return self._value
682 else:
–> 683 raise self._value
685 def _set(self, i, obj):


Traceback (most recent call last):
File “C:\Users\sanjana\AppData\Local\Continuum\anaconda3\lib\multiprocessing\managers.py”, line 234, in serve_client
request = recv()
File “C:\Users\sanjana\AppData\Local\Continuum\anaconda3\lib\multiprocessing\connection.py”, line 251, in recv
return _ForkingPickler.loads(buf.getbuffer())
AttributeError: Can’t get attribute ‘Item’ on <module ‘pyIUDX.rs.item’ from ‘C:\Users\sanjana\AppData\Local\Continuum\anaconda3\lib\site-packages\pyIUDX\rs\item.py’>

When I run the same notebook via Google colab, I am able to run it.
Can someone please tell me what the issue could be. I am quite clueless at the moment.

Hi Sanjana.
It seems to work fine on Linux Systems.
Let me try it on a windows system and get back to you.