pyIUDX packages issue

hello team,

I’m facing issue while importing the pyIUDX sub modules package’s,
pyIUDX package’s installed successfully. I’m trying to run this the application on AWS EC2 ,

Hi. This only works on Python3.

hello admin i have tried with python 3.6

Looks like a syntax error.
Also, try not to name the file you are editing as cat.py or rs.py or item.py or pyIUDX.py.
Can you also send me a snippet of the code you are trying?
Have you tried the jupyter notebooks?

yes i’ve tried. i have not edited or named the files as cat.py and item.py or rs.py any thing like that, these are the libs installed with pyIUDX package’s.

here im trying to get all the rainfall stations details data.and creating one .json with all the details.

please check in def connectCat method. has one additional closing bracket. which in causing the issue.

lib_error

its one function is Catalogue class i have installed it from github

Did you install the package using pip only?
You need to install it like this

pip install git+https://github.com/iudx/pyIUDX

Uninstall pyIUDX and reinstall it this way.

yes wtih this cmd pip install git+https://github.com/iudx/pyIUDX

That’s strange. You seem to have an older version of the SDK.
Can you try on a different computer? Also, you can see pyIUDX/examples/scripts for examples which work.